iOS Support Matrix

I’ve been looking for a concise representation of versioning and architecture support in the iOS world.  lumenEssence depends on an available serial port and that went by the wayside with the Lightning connector.  But now I want to support BLE which is more readily available with the ARM64 iPhones which are incompatible with the iOS 6.0 version I need for the iPhone 4.  Which iOS version works where?  How do I need to build the openframeworks libraries?  Frustrating.

Luckily there is this great support matrix available that’s helped me understand all of the dependencies and is helping me with scripting different builds for different platforms.

Leave a Reply

Your email address will not be published. Required fields are marked *